Vulnerability Scanning Solutions, LLC.
Home
Our Process
Residential
Corporate
What We Scan For
Sample Report
Client List
Terms
Contact Us
What We Scan For
Family: CGI abuses : XSS --> Category: infos

IMP_MIME_Viewer_html class XSS vulnerabilities Vulnerability Scan


Vulnerability Scan Summary
IMP_MIME_Viewer_html class is vulnerable to XSS attacks

Detailed Explanation for this Vulnerability Test

The remote server is running at least one instance of IMP whose version
number is between 3.0 and 3.2.1 inclusive. Such versions are vulnerable
to several cross-scripting attacks whereby a possible hacker can cause a
victim to unknowingly run arbitrary Javascript code simply by reading an
HTML message from the attacker.

Announcements of the vulnerabilities can be found at :

- http://marc.theaimsgroup.com/?l=imp&m=105940167329471&w=2
- http://marc.theaimsgroup.com/?l=imp&m=105981180431599&w=2
- http://marc.theaimsgroup.com/?l=imp&m=105990362513789&w=2

Note : Nessus has acertaind the vulnerability exists on the target
simply by looking at the version number of IMP installed there. If the
installation has already been patched, consider this a false positive.

Solution : Upgrade to IMP version 3.2.2 or later or apply patches found
in the announcements to imp/lib/MIME/Viewer/html.php.

Threat Level: High

Click HERE for more information and discussions on this network vulnerability scan.

VSS, LLC.

P.O. Box 827051

Pembroke Pines, FL 33082-7051

Vulnerability Scanning Solutions, LLC.