Family: CGI abuses --> Category: attack
PmWiki < 2.1.21 Global Variables Overwrite Vulnerability Vulnerability Scan
Vulnerability Scan Summary
Checks for a remote file include flaw in PmWiki
Detailed Explanation for this Vulnerability Test
The remote web server contains a PHP script that is affected by a
global variable overwriting vulnerability.
The version of PmWiki installed on the remote host contains a
programming flaw in 'pmwiki.php' that may allow an unauthenticated
remote attacker to overwrite global variables used by the application,
which could in turn be exploited to execute arbitrary PHP code on the
affected host, subject to the rights of the web server user id.
Note that successful exploitation of this issue requires that PHP's
'register_globals' and 'file_uploads' settings be enabled and that the
remote version of PHP be older than 4.4.3 or 5.1,4.
See also :
Upgrade to PmWiki version 2.1.21 or later.
Medium / CVSS Base Score : 4.9
Click HERE for more information and discussions on this network vulnerability scan.