Family: CGI abuses : XSS --> Category: infos
SquirrelMail < 1.4.4 XSS Vulnerabilities Vulnerability Scan
Vulnerability Scan Summary
Checks for Three XSS Vulnerabilities in SquirrelMail < 1.4.4
Detailed Explanation for this Vulnerability Test
The target is running at least one instance of SquirrelMail whose
version number suggests it is vulnerable to one or more cross-site
scripting vulnerabilities :
- Insufficient escaping of integer variables in webmail.php allows a
remote attacker to include HTML / script into a SquirrelMail webpage
(affects 1.4.0-RC1 - 1.4.4-RC1).
- Insufficient checking of incoming URL vars in webmail.php allows an
attacker to include arbitrary remote web pages in the SquirrelMail
frameset (affects 1.4.0-RC1 - 1.4.4-RC1).
- A recent change in prefs.php allows a possible hacker to provide a
specially crafted URL that could include local code into the
SquirrelMail code if and only if PHP's register_globals setting is
enabled (affects 1.4.3-RC1 - 1.4.4-RC1).
***** Nessus has acertaind the vulnerability exists on the target
***** simply by looking at the version number of Squirrelmail
***** installed there.
Solution : Upgrade to SquirrelMail 1.4.4 or later.
Threat Level: Medium
Click HERE for more information and discussions on this network vulnerability scan.